Commusoft - Commusoft Status Page Update - Support Lines – Incident details

All systems operational

Commusoft Status Page Update - Support Lines

Resolved
Degraded performance
Started 2 days agoLasted 21 minutes

Affected

UK Datacenters

Degraded performance from 10:45 AM to 11:06 AM

Support

Degraded performance from 10:45 AM to 11:06 AM

Updates
  • Resolved
    UTC
    Resolved
    This incident has been resolved.
  • Investigating
    UTC
    Investigating

    As of right now, we are aware of a problem preventing users from being able to call our Support line. Our team is investigating this matter urgently.

    If you cannot reach us by phone, please send us an email or start a chat and we will pick it up there.

    We apologise for the inconvenience, and we will keep you posted.