Web Application experiencing degraded performance

Resolved
Commusoft Status Page Update - Web Application

Started
19 Jul, 23 at 9:44 AM
Status
Resolved after about 3 hours

Impact

Operational
Affected
UK Datacenters
Web Application
  • Resolved
    Resolved

    This incident has been resolved.

  • Monitoring
    Monitoring

    We implemented a fix and are currently monitoring the result.

  • Investigating
    Investigating

    As of right now, we are aware of a problem with the latest Google Chrome update version 115.0.5790.99, our team is investigating this matter urgently. The chrome update is causing a visual display issue on the home screen and showing locks on the diary event.

    Whilst we investigate we would recommend you use an alternative browser such as Edge or Brave.

    We apologise for the inconvenience, and we will keep you posted.