Scheduled for 14 Feb, 26 at 7:00 AM – 9:00 AM
Affects
US Datacenters
Under maintenance from 7:00 AM to 9:00 AM
Integrations
Under maintenance from 7:00 AM to 9:00 AM
Mobile Application
Under maintenance from 7:00 AM to 9:00 AM
Web Application
Under maintenance from 7:00 AM to 9:00 AM
Completed
14 Feb, 26 at 9:00 AMCompleted
14 Feb, 26 at 9:00 AMMaintenance has completed successfully
In progress
14 Feb, 26 at 7:00 AMIn progress
14 Feb, 26 at 7:00 AMMaintenance is now in progress
Planned
14 Feb, 26 at 7:00 AMPlanned
14 Feb, 26 at 7:00 AMWe will be performing our Regular Server Maintenance Activity in US Production Servers this Weekend.
Date : Feb 14 2026 - Saturday
This will help us to improve the Server performance.
During this activity the website and mobile service will be down.
Post maintenance we will verify the functionalities and open up the access to the public.