Commusoft - Commusoft Status Page Update - Google Calendar Integration UK and US – Incident details

All systems operational

Commusoft Status Page Update - Google Calendar Integration UK and US

Resolved
Operational
Started 11 days agoLasted 1 day

Affected

UK Datacenters

Operational from 8:37 AM to 9:36 AM, Degraded performance from 9:36 AM to 11:11 AM

Integrations

Operational from 8:37 AM to 9:36 AM, Degraded performance from 9:36 AM to 11:11 AM

US Datacenters

Operational from 8:37 AM to 11:11 AM

Integrations

Operational from 8:37 AM to 11:11 AM

Updates
  • Resolved
    Resolved

    The authentication issue has been fully resolved.

    To restore full functionality, please disconnect and reconnect your Google Calendar integration. The steps are outlined in the in-app notification. Once reconnected, any new records created after the setup will include full edit and delete sync capabilities.

  • Monitoring
    Monitoring

    The Google Calendar integration temporarily lost Google Store authentication and must be reauthorized.

    • US Clients: Service restored. Users must disconnect and reconnect the integration for it to resume normal operation.

    • UK Clients: Awaiting Google approval.

      • Workspace accounts: Can disconnect and reconnect now to restore functionality.

      • Personal Gmail accounts: Will see an authorization warning. They can wait for approval or manually trust the connection.

  • Update
    Update

    Our team is still working on this, and we'll update you as soon as we have more information.

  • Identified
    Identified
    We are continuing to work on a fix for this incident.
  • Investigating
    Investigating

    As of right now, we are aware of a problem preventing users from being able to access our Google calendar integration. Our team is investigating this matter urgently. We apologise for the inconvenience, and we will keep you posted.