All systems operational

Resolved
Commusoft Status Page Update - Web Application

Started
4 Apr, 22 at 8:26 AM
Status
Resolved after 8 minutes

Impact

Degraded performance
Affected
UK Datacenters
Web Application
  • Resolved
    4 Apr, 22 at 8:34 AM

    We have resolved this incident.

  • Investigating
    4 Apr, 22 at 8:26 AM

    As of right now, we are aware of a problem preventing some users from being able to access Commusoft Web. Our team is investigating this matter urgently. We apologise for the inconvenience, and we will keep you posted.