All systems operational

Resolved
Commusoft Status Page Update - Web Application

Started
25 Mar, 22 at 11:29 AM
Status
Resolved after 5 minutes

Impact

Operational
Affected
UK Datacenters
Web Application
  • Resolved
    25 Mar, 22 at 11:34 AM

    We have resolved this incident.

  • Investigating
    25 Mar, 22 at 11:29 AM

    As of right now, we are aware of a problem preventing some users from being able to access Commusoft Web. Our team is investigating this matter urgently. We apologise for the inconvenience, and we will keep you posted.